Cisco 2960. Работаем с vlan’ами

Важно заметить, что перед тем, как перевести порт в нужный влан, он должен существовать. Если перевести порт в несуществующий влан, результаты непредсказуемые. Например, на форуме ciscolab.ru, один из пользователей рассказал о том, что если добавить в транк несуществующий влан, то свич уходит в даун. Вланы создаются через базу данных vlan’ов (вводится в конфигурационном режиме):

cisco#vlan database
cisco(vlan)#vlan №ВЛАНА

Там же можно и удалять вланы. Так же стоит запомнить, что новосозданные вланы появляются после того, как вы выйдете из vlan database с помощью команды exit:

cisco(vlan)#exit
APPLY completed.
Exiting….

Перевод порта в определённый влан осуществляется следующей командой (эта команда вводится в конфигурационном режиме, в настройках определённого порта):

cisco(config-if)switchport access vlan №ВЛАНА

Обычно перед этой командой выполняют ещё такую:

cisco(config-if)switchport mode access

Это даёт понять, что мы точно хотим использовать этот порт как обычный, а не как транковый. Эта команда не отображается в конфигурации свичей более ранних версий, таких как Cisco Catalyst 2900XL, но не вызывает ошибки, если её ввести.
Теперь рассмотрим вариант с транками.

Для переключения порта в режим транка используем следующую команду:

cisco(config-if)switchport mode trunk

Дальше нужно перечислить те вланы, которые мы хотим пропускать через этот транковый порт:

cisco(config-if)switchport trunk allowed vlan 101-107,110

Если в дальнейшем нужно будет пробросить ещё несколько вланов, то тут нужно быть внимательным, ибо для этого нужно будет после слова vlan в строке добавить ключевое слово add, иначе все существующие вланы на этом порту затрутся и останутся только вновь прописанные:

cisco(config-if)switchport trunk allowed vlan add 201,230

Если 2 свича связаны напрямую кабелем или оптикой то такая схема будет работать. Если вам нужно пробросить вланы через несколько свичей – эти вланы должны быть проброшены на каждом свиче, через который они пробрасываются. Это очень важно и часто возникают ошибки, потому что, на каком-то промежуточном свиче не существуют эти вланы.

Но что делать если у вас свичи находятся в разных концах города и связь между ними предоставляется через канал связи провайдера. Напомню, что здесь имеется ввиду не интернет соединение, а именно ТРАНСПОРТ от одного источника к другому. Для этих целей применяется инкапсуляция. Обычно применяют dot1q. Вланы, так сказать, инкапсулируются вланы и передаются как одно целое. Что бы включить инкапсуляцию на транковом порту выполняем следующее:

cisco(config-if)switchport trunk encapsulation dot1q

Это делается на всех транковых портах которые имеют соединение через чей-то транспорт, в том числе у провайдера. Я недавно сам столкнулся с тем, что нужно было пробросить вланы ещё и у провайдера (напомню, в данном контексте провайдер – это тот, кто предоставляет транспорт, а не интернет).

Напомню, что есть 2 вида соединения – оптика и канал (транспорт). Главное отличие в том, что оптика – это прямой участок между без какого-либо промежуточного оборудования, а транспорт – может проходить через оборудование не одного провайдера. Поэтому, если вам нужно пробросить вланы через оптику – вы просто прописываете их на обеих концах и всё. А если через транспорт – то их нужно прописать на каждом из оборудования провайдера (другими словами пробросить вланы на каждом из оборудовании).

Настройка Cisco Catalyst-3560 (L3 switch):

1) Зададим IP – адрес коммутатору:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)# no shutdown

2) Создадим vlan-ы:

Switch(config)#vlan 2
Switch(config-vlan)#name net2
Switch(config)#vlan 3
Switch(config-vlan)#name net3

3) Создадим vlan – интерфейсы:

Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.3.1 255.255.255.0

5) Назначим trunk порты (подключение коммутатор-коммутатор):

Switch(config)#finterface fastEthernet 0/1
Switch(config-if)#switchport trunk encapsulation dot1q

6) Включим маршрутизацию:

Switch(config)#ip routing

7) Настроим DHCP-сервер (имеем 2 vlan-интерфейса, к которым привязаны разные подсети, нужно в каждую подсеть раздать адреса динамически с дефолтным маршрутом)

7.1) Исключаем адреса шлюзов из доступных адресов для раздачи:

Switch(config)#ip dhcp excluded-address 192.168.2.1
Switch(config)#ip dhcp excluded-address 192.168.3.1

7.2) Затем прописываем пулы адресов для раздачи:

Switch(config)#ip dhcp pool net2
Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.2.1
Switch(config)#ip dhcp pool net3
Switch(dhcp-config)#network 192.168.3.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.3.1

Настройка Cisco Catalyst-2960 (L2 switch):

1) Зададим IP – адрес коммутатору:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)# no shutdown

2) Зададим шлюз коммутатору:

Switch(config)#ip default-gateway 192.168.1.1

3) Создадим vlan-ы:

Switch(config)#vlan 2
Switch(config-vlan)#name net2
Switch(config)#vlan 3
Switch(config-vlan)#name net3

4) Назначим access порты (подключение ПК-коммутатор):

Switch(config)#interface range fastEthernet 0/2-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 2
Switch(config)#interface range fastEthernet 0/11-20
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 3

5) Назначим trunk порты (подключение коммутатор-коммутатор):

Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk

Оставьте комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *